Using Mulberry 3.1 on Windows
and Macintosh Machines

A Computing Services Publication: June 21, 2004


Mulberry is a commercial email client developed by Cyrusoft International, Inc. This document will walk you through the most commonly used email functions. For information on installing and navigating Mulberry windows, read Mulberry 3.1 for Windows and Macintosh.

This document contains the following sub-headings:

Other documents of interest:


Messages

View and Read Messages

Mulberry "holds" your incoming messages in the INBOX. Once logged on to the server, you can view the contents of the INBOX. Once you have opened and read a message, you can decide what you want to do with it.

Follow these steps to view a message:

  1. In the server window, double-click on your INBOX.
    The INBOX mailbox window appears. The window contains captions to your messages.
  2. Double-click on the caption of the message you want to read.
    The text of the message appears.

    Note: You can set a default size and location for message windows. Size and position the message window to your tastes, then select Window > Save Default Window.

The Message Window

The Message window displays the contents of incoming messages. The window title is the text of the subject or if the subject line is empty, the address of the sender.

The message window is divided into three main sections:

  • Header Displays the addresses, subject and date the message was sent. Also includes the navigation buttons and other buttons used to manipulate the message.
  • Parts Can be expanded or collapsed. In its collapsed state (shown above), the message displays the total number of MIME parts to the corresponding message. A button is used to display the message header and a pop up menu is used to change the display format and select a mailbox to copy the message to. In its expanded state, the message also shows a list of each MIME part. This allows you to manipulate the individual parts.
  • Text Display Used to display any text parts in the body of the message.

Moving Between Messages

The message window header includes four navigation buttons. These buttons are used to display a different message in the current message window without having to open another window.

Follow these steps to move between messages:

  • Click Del-Next to delete the current message in the mailbox and display the next message in the window.
  • Click Prev to display the previous message in the mailbox.
  • Click Next to display the next message in the mailbox.

Reply, Forward and Delete Messages

Follow these steps to reply to a message:

  1. View the message or highlight the message caption of an unopened message.
  2. Select Message > Reply (or click the Reply icon in the Message window).
    A Reply To Message window appears with the To: field and Subject field completed. A Re: precedes the original subject text.
  3. Enter the reply text in the message window.
  4. Click Send (upper right corner of the message window).
    Note: To reply to everyone who received the original message, press Alt + Reply. Click Reply All, then click Create Reply.

Follow these steps to forward a message:

  1. View the message or highlight the message caption of an unopened message.
  2. Select Message > Forward (or click the Forward button in the Message window).
    The Forward Message dialog box appears.
  3. Click Forward.
  4. Enter the recipient name/email address and the message text.
  5. Click Send (upper right corner of the message window).

Follow these steps to delete a message:

  1. View the message or highlight the message caption of an unopened message.
  2. Click on the Delete icon, (e.g., trash can icon) or sSelect Message > Delete.
    The Delete button changes to an Undelete button and the message caption is marked for deletion. A red strikeout line appears over the message and the Expunge icon is activated.
  3. Click Expunge.
    A dialog box appears asking if you are sure you want to expunge the deleted messages. Once a message had been expunged it is permanently deleted.
  4. Click Expunge.

Follow these instructions to Undelete a Message:

If you mark a message for deletion, but later decide you want to keep it, follow these steps to undelete the message:

  1. In the mailbox window, click the message caption that you want to undelete.
  2. Click on the Undelete icon. The message is returned to its undeleted state.

    Note: You must undelete messages before you expunge. You cannot retrieve expunged messages.

Sending Messages

Follow these steps to send a message:

  1. Click the Draft button in the Mailbox window or select File > New Message.
    An untitled message window appears.

  2. In the "To" field, enter the e-mail address of the person you want to send the mail to. You can also enter e-mail addresses in the Cc (carbon copy) or Bcc (blind carbon copy) fields.
    Note: If you list more than one user, separate e-mail addresses with a comma.
  3. Enter a brief description of the message content in the "Subject" field.
  4. Enter the text of the message in the large text area.
  5. Click Send.

Sign and Encrypt Options on the Windows Platform

The Sign and Encrypt buttons are located on the Windows Mulberry Draft message window. These two options are intended to add additional security to your outgoing email by letting you attach a secure signature to your message and to turn on encryption for the message being sent. These options are an addition to an already secure mail client. You must use plugins for these to work which are not provided in this version of Mulberry. For more information, visit the CyrusSoft website.

Attachments

In Mulberry, you can attach word processing, spreadsheet, image, or sound files to your message. You can also read attachments that have been sent to you.

Follow these steps to attach a file to your message:

With the message window open, click Attach. The Open window appears.

  1. Locate and highlight the file you want to send, then attach the file as follows:
    • Click Open (Windows)
    • Click Add (Macintosh)
  2. To attach additional files:
    • Repeat the above steps for each file you want to attach (Windows).
    • Select the file(s) you want to attach, then click Done.

    Note: The Parts field will indicate that there are more than one part or attachment to the message you are sending.

Follow these steps to read an attachment:

  1. With the message window open, click the Parts arrow (if necessary) to display a list of the message parts.
  2. Double-click the file that you want to extract.
    The appropriate program is launched and the file is opened.
  3. If you want to save a copy of the file on your machine, follow the normal steps for that program.

    Note: You can set your Attachment preferences to automatically view or save when opening an attachment or to set a default save location. To do this, select File > Preferences, select the Attachment tab, then click the Sending or Receiving tab.

Spell Check

Mulberry offers a spell check feature. Follow these steps to spell check your message before sending.

  1. With the message window open, address and compose your message text.
  2. Click Spelling. The Check Spelling window appears.
  3. Select one of the following actions:
    • Add - add a "wrong word" to your dictionary
    • Edit - edit your dictionary; used if you want to manually add or remove words
    • Replace - replaces the "wrong word" with the selected word in the dictionary list
    • Skip - skips the currently identified "wrong word" and moves you to the next misspelling
    • Replace All - replaces every instance of the "wrong word" with the word that is currently selected in the word dictionary list
    • Skip All - ignores every instance of the "wrong word" and moves to the next misspelling
  4. Repeat until the Spell Check Complete message appears.
  5. Click OK.
  6. Send the message.

    Note: You can edit your spelling options. To do this, select Edit> Spelling Options or click Options... on the Check Spelling window. The Spelling Options window appears. For example, to highlight spelling errors, select Use Background Colour for Errors. Click on the colored box to select a background color. Make any other desired changes and click OK.

    Note: By default, Mulberry is set to automatically spell check your text. To reset this feature, select Edit > Spelling Options > Check Spelling whilst Typing.

Search and Match Messages

Mulberry's search feature provides a quick and easy way to select or display messages of interest within a mailbox window. By default, each mailbox window displays all messages that are available when opened. You can choose to limit this list of messages by constructing a search pattern.

  1. In the header section of the Mailbox window, click Search.
    The Message Search window appears.
  2. From the Find Messages whose drop-down menus, select your search criteria.
    • Click the first Find Messages whose drop-down menu, then select the component of a message you want to search for (e.g., from address).
    • Click the second Find Messages whose drop-down menu, then select how you want to match the chosen message component (e.g., contains).
    • In the Find Messages whose text field, enter the text you want to search for.
  3. Click Search.
    Once found, the message(s) that match the search criteria appear in the Mailbox window you were searching on. To redisplay that mailbox, de-select the Match button.

    Note: Another quick way to search for messages that have common elements within your mailbox is to hold down the Alt button (Windows) or Options button (Macintosh) and click on an item under one of the columns in a message line (i.e., From/To, Date Sent or Subject/Thread). A complete list of all messages that match your selection will be displayed.

    The results are displayed in the order the messages were received. Click on the Match icon to return to the complete message list.

Read Receipts

You can send requests for and respond to read receipts using the Message Disposition Notification (MDN) e-mail standard.

Note: Read Receipts are handled solely at the discretion of the recipient of a message. There is no guarantee that your request for a read receipt will be honored. Recipients can turn off read receipt processing.

Follow these steps to use the Read Receipt function:

  1. Mulberry offers three methods of responding to read receipts. They are controlled by options in the Message panel, Options tab in your Preferences file. To set your preference, select File > Preferences (Windows) or Mulberry > Preferences (Macintosh). The Remote Preferences window appears.
  2. If it's not already selected, select the Advanced radio button.
  3. Select the Message tab and click Options. In the Sender Read Receipt Request section, select the method you want to use for read receipts.

    Always Send Read Receipt - A read receipt will always be sent when you open and view a message with a read receipt request.

    Never Send Read Receipt - A read receipt will never be sent even if requested by the sender of a message you read

    Prompt to Send Read Receipt - If a read receipt request is detected in a message you are reading, Mulberry will prompt you as to whether you want to send a read receipt back to the sender of the message. (This is the Mulberry default setting.)
    1. Click OK to close the Remote Preferences window.
    2. To send a message with a read receipt, select File > New Message, or click Draft on the Toolbar to open the Draft window.
    3. From the main Mulberry menu, select Draft > Notifications > Return Receipt or click on Receipt icon on the Toolbar to send this message with a Read Receipt.
      Once the message is sent, a Disposition notification appears in your Inbox stating that the message was displayed to the recipient.

Text Macros

Text Macros provide a fast, convenient way to insert commonly used text into a message draft. Follow these steps:

  1. Select Edit > Text Macros. The Edit Macros dialog box appears.
  2. Click New to create a new macro. The Edit Macro dialog box appears.
  3. In the Name field, enter a short and easy to remember name for your macro (e.g., testmacro). Type in or copy/paste the text of the message in the other field. Click OK.
  4. In the Edit Macros window, select the macro and click Choose.
  5. You'll be prompted to type a key that will trigger your macro expansion. The same key will apply to all macros you create. Although other keys may work, the default is to use Shift + Enter (Windows) or Shift + Return (Macintosh). Click OK to close the Edit Macros dialog box.
  6. To create a message using your Text Macro, select File > New Message, or click Draft on the Toolbar to open the Draft window.
  7. In the message area of the Draft, enter the name of the macro you want to use (e.g. testmacro), then press the Control key that you selected for your macro(s) (e.g., Shift + Enter or Shift + Return). The macro message information appears.

Using Sent Mail

Creating a Sent Mail Mailbox

Follow these steps to create a sent mail mailbox:

  1. In the Servers pane with the Mail tab displayed, highlight the INBOX.* folder (located below the Subscribed folder).
  2. Click the Create icon (located at the top of the Servers window). The Create Mailbox dialog box appears.
  3. For the name of your Sent Mail folder enter, Sent Mail then click OK.

    Your new Sent mailbox is created. Now you must set up your mailbox to copy all outgoing messages. Complete the following steps:

  4. Select File > Preferences (Windows) or Mulberry > Preferences (Macintosh).

    The Remote Preferences window is displayed.
  5. Select Simple on the right side of the window instead of Advanced.
  6. At the bottom of the dialog box, select the Copy Outgoing Messages option.
  7. In the Default field, select the Sent Mail mailbox from the drop down list. (This is the mailbox you just created.)
  8. Click OK.
    If you want, you can reselect Advanced before exiting the Preferences window.

    Note:
    The preferences are set. Every message you send will be copied to your Sent Mail mailbox. Keep in mind that these copied messages use some of your mail quota. Be sure to delete and expunge periodically to avoid reaching your mail capacity.

Using User-Defined Labels

The user-defined labels can be used to categorize messages in your mailbox. To create user-defined labels, complete the following steps.

  1. From the Preferences Advanced window, click on the Display tab.
  2. Click on Labels.
    The following window is displayed.
  3. Enter a name for your label and select the label attributes. Click OK to close the preferences.

Using the User-Defined Labels

To apply one of the pre-defined labels to a message in your inbox, highlight the message and select Message > Flags. Select one of the pre-defined names located at the bottom of the pop-up window. The properties will be applied to the message.

 


Address Books

Mulberry offers address book functionality so you can retrieve e-mail names and addresses quickly from a server. For your convenience, an address book named with your userID is already provided for you on the server. (An address book that lists ~all andrew users~ is also provided).

Opening the Address Book Manager

  1. To access address book information select Address > Address Book Manager from the Mulberry menu.

    Note: You can also access Address book information by selecting the Contacts tab on the Server pane.

    The Address Book Manager window is displayed.

    Note: Address books on the server appear under the Address Books listing.

  2. To open an Address book do one of the following:
    • On a Macintosh, click the triangle next to the Address book.
    • On Windows, click the plus (+) sign next to the Address book.
  3. Highlight the address book you want to open and click Open or double-click on the address book.

Adding a New Contact

Follow this procedure to add a single name to an address book.

  1. Open the address book to which you want to add a new user.
  2. Click Single to add a user. The Address Edit window is displayed.
  3. Complete the information and click OK.

    The new contact will appear in alphabetical order in the Single Users panel of your address book.

Adding a Group

Follow this procedure to add a group to the address book.

  1. Open the address book to which you want to add the group.
  2. With your cursor in the Group pane, click Group to add a group.
    The Group Edit window is displayed.
  3. Enter a Nick-name and Group Name. To enter a list of e-mail addresses for the people who will be in the group, use one of the following options:
    • Type the list of e-mail addresses in the Address field and click OK.

    Click OK and reopen the group address book. Drag single user addresses from an existing mailing list into the Address field for the Group.

    The new group will appear in the Groups pane of your address book.

Search for an Address

Follow these steps to search for an address.

  1. To search for an address, you must first designate which address book(s) you want to search in. In the third column of blue diamonds, check the diamond for each address book you want to include in your search.
  2. Click on the Search icon.
    The Address Search dialog box appears.
  3. From the Find Items drop-down menu, select your search criteria:
    • Click the first Find Items drop-down menu, then select which address field you want to search for (e.g., full name).
    • Click the second Find Items whose drop-down menu, then select how you want to match the text with an address entry (e.g., contains).
  4. Click Search.
    The address(es) that match the search criteria appear in the Mailbox window.
  5. Double-click an address to view all of the address fields. To compose a message to this e-mail address, select an address, then click Draft (top right corner).
  6. Click Clear to remove the search address(es); to remove the search criteria, deselect the Match button.

Address Expansion

When configured properly, Mulberry offers the ability to expand partial addresses from within a message draft window. Follow these steps:

  1. From the Mulberry menu, select Address > Address Book Manager.
    The Address Book Manager window is displayed.
  2. On the IMSP Address Books entry do one of the following:
    • On a Macintosh, click the triangle
    • On Windows, click the plus (+) sign
  3. Find the ~all andrew users~ listing.
  4. Click on the middle diamond beside the address book to enable the Nick Name Resolution feature. A check mark verifies that this feature is enabled.
  5. Click on the diamond on the right side to enable searching on this address book. A check mark verifies that this feature is enabled.
  6. Close the Address Book Manager.

    Note: You may also want to configure your personal address books using these steps.

Using Address Expansion

Follow these steps to use address expansion.

  1. Select File > New Message or click Draft.
    The Draft message window is displayed.
  2. Type part of the userID or person's name that you want to send an e-mail to. For example, if you know that the name contains "joe", type joe in the "To" field and press Ctrl + Enter or the tab key (Windows) or Apple + Return (Macintosh).
    1. The Choose an Address dialog box appears. It lists all names that match your input.
    2. Scroll through the list and double-click on the correct e-mail address. The e-mail address is pre-filled in the "To" area of your message draft.
      Note: If you do not select a name from the list and click cancel, be aware that the name you entered in the To: field will be appended with "@andrew.cmu.edu".

Sharing Your Address Book

Follow these steps to share your address book with another user.

  1. Select Address > Address Book Manager. The Address Book Manager window opens.
  2. Highlight the address book that you want to give someone access to.
    Note: You can only give access to address books that you control.
  3. Click Details. The Address Book dialog box appears.
  4. Select the Access Control List tab (Windows) or click Access (Macintosh).
  5. Click New User. The New User ACL dialog box appears.
  6. Type the userID of the person you want to give access to.
  7. Use the Set buttons to select the access rights you want to give. Choose from Lookup, Read, Write, Create, Delete, or Admin.
  8. Click OK. The user will have the access rights that you granted them.

Using Bulletin Boards in Mulberry

Bulletin boards are a popular method of communicating with groups of people. The number of bboards available on campus may seem overwhelming, but they are organized into appropriately named directory structures that make it easy for you to find information.

Posting to a Bulletin Board

Enter post+BBOARD_NAME@andrew.cmu.edu in the To: or Cc: field of a new message. Where BBOARD_NAME is the name of the bulletin board to which you want to post.

Searching for Bulletin Boards

To search for a specific bulletin board or for a group of bulletin boards, you can create a display hierarchy based on the desired search criteria. Follow these steps:

  1. With your cursor positioned inside the Server pane, select Mailbox > Display Hierarchy > New Display Hierarchy.
    Note:
    If the Display Hierarchy option is not available, make the Servers window the active window and try again. You must complete this step before you proceed.
  2. In the Search in account field, select Cyrus.
  3. In the for mailboxes field, select whose name contains.
  4. Type the search key word. For example, entering official will find all bulletin boards whose name contains "official".
  5. Click OK.
    Mulberry adds the select search results to the bottom of your Folders list.
    Note: The program does not automatically scroll to this new entry. If the bottom of the list is not visible to you, it may appear as if nothing happened. You must scroll down to view the new entry.

Removing a Displayed Hierarchy from your Folders List

Follow these steps to remove the Display Hierarchy from your folders list.

Note: Before you proceed, be sure that there are no open folders inside the Display Hierarchy. Removing a Display Hierarchy with open folders causes Mulberry to quit unexpectedly.

  1. Select the Hierarchy from your Folders list.
  2. Select Mailbox > Display Hierarchy > Remove Display Hierarchy.
  3. Click OK at the confirmation prompt.

Subscribing and Unsubscribing

If you know the exact name of the bulletin board that you wish to subscribe to, you can simply open the bulletin board and make it one of your subscribed mailboxes.

How to subscribe when you know the Bboard name:
Follow these steps to subscribe to a bulletin board when you know the exact name.

  1. Select File > Open Mailbox....
    The Open Mailbox dialog box is displayed.
  2. In the Mailbox Name field, type the name of the bulletin board you want to subscribe to.
  3. Click OK (Windows) or Open (Macintosh).
    Note:
    If you entered a valid bulletin board name, the board should open. If the name was invalid, an error message appears.
  4. Select Mailbox > Subscribe.

How to subscribe when you are unsure of the Bboard name:
Before you can select and subscribe to the bboard, you must search for the bboard. See Searching for Bulletin Boards to create a display hierarchy.

  1. Scroll through the list of bulletin boards in the display hierarchy until you find the one you want to subscribe to, for example, "official.computing-news".
  2. Highlight the desired bulletin board by click on it.
  3. Select Mailbox > Subscribe.

    The bulletin board will be added to your Subscribed folder.

How to unsubscribe from a bboard:
Follow these steps to unsubscribe from a bulletin board.

  1. Select the bulletin board from which you want to unsubscribe.
  2. Select Mailbox > Unsubscribe.

    The bulletin board will be removed from your Subscribed folder.

Creating a New Graffiti or Assocs Bulletin Board

Follow these steps to create a new graffiti or assocs bboard through Mulberry:

  1. Select Mailbox > Create.
    The Create Mailbox dialog box is displayed.
  2. Verify that the Full Pathname option is selected.
  3. Verify that Cyrus is selected under the in Account field.
    If it is not, click Cancel and then select the "Cyrus" server in your Servers window. You then will have to start the process over again.
  4. In the Name field, type the name of the bboard that you are creating, e.g., graffiti.mudge2d or assocs.frenchclub.
  5. If you would like to subscribe to the bboard once it has been created, click on the Subscribe when Created checkbox.
  6. Click OK.
    The bboard is created.

    Note: To remove a bboard once it has been created you must contact the Help Center at 8-HELP.

Checking for New Messages in Bulletin Boards or Personal Folders

Mulberry notifies you when new messages arrive in a particular bulletin board (or in any mailbox on any mail server for that matter) by applying a new message icon to that mailbox. All bulletin boards/mailboxes that appear under the Subscribed folder are ones that you have subscribed to.

Local Mailboxes

Each member of the Carnegie Mellon campus community is allocated a limited amount of space on our mail server for their mail account. If you tend to store and archive e-mail messages, you may want additional storage capacity. You can accomplish this by setting up a local mailbox account to store mail on your computer hard drive. To do this, follow these steps.

  1. Select File > Preferences (Windows) or Mulberry > Preferences (Macintosh).
    The Remote Preferences window is displayed. Make sure the Advanced view is displayed.
  2. Select the Accounts tab (Windows) or click Accounts (Macintosh).
  3. Select New from the Account pull down menu.
    The Create New Account dialog box appears.

    Make the following changes:

    • Type a unique name, such as Local Mail in the Account Name field
    • Select Local Mailbox from the Account Type pull down menu.
  4. Click OK to close the Create New Account window.
  5. From the Accounts tab, select Specify Location to enable this feature.
  6. Click Choose to specify the location where you want Mulberry to store your local mailboxes, as shown below.

    Note: It is recommended that you specify the location where Mulberry will store local mailboxes. This should be a place on your hard drive where you normally store your documents (e.g. "C:\My Documents" or the "Documents" folder of your Macintosh hard drive). If you do not specify the location, Mulberry will default to use the Mulberry installation directory.

  7. Click OK in the Preferences window to create the local mailbox account and close the Remote Preferences window.

    The name of the local mailbox account that you've just created will appear in the Server pane (see the circled area in the screen shot below). You may need to scroll to the bottom of the Server pane to see your local account.

    Note: In order to drag and drop mail into your local mailbox, you'll need to create a mailbox under it (see Creating a Mailbox in a Local Account).


Creating a Mailbox in a Local Account

Follow these steps to create a mailbox in a local account.

  1. Click on the name of a local account in the Server window to select it.

    Note: The icon next to the local account name is a removable disk.
  2. Click Create in the Server window. The Create Mailbox dialog box appears.
  3. In the Mailbox Name field, enter a distinguishing name (e.g. Local Mailbox) for the mailbox.
  4. Click OK to create the mailbox. The Create Mailbox dialog box disappears.
  5. You can now copy messages to and from your local account from any server account (IMAP, POP3, Local Mail) defined in your configuration.

    Note: Carnegie Mellon does not recommend the use of POP3.