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Eclipse

Eclipse is a free open-source Java environment available from http://eclipse.org. Eclipse is a Java program, but it uses a custom user
interface toolkit that does not run on all platforms that supports Java 2. Check the web site for supported platforms. Eclipse requires a Java 2
runtime, so you need to install the Java 2 SDK first before installing Eclipse. You can download the SDK from http://java.sun.com/j2se/. For
this course, you will want the J2SE 1.4.2 release. (If you have a Macintosh, the Java 2 SDK is already installed)

Starting Eclipse

When you start Eclipse, a startup screen appears, and the program spends some time loading various modules.

%erllpse
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Eclipse will ask you for your workspace (where on your computer the projects you are working on will be stored.) The prompt will look like
the following: Click on the Browse... button to navigate to the directory of your choice if it is not already selected or in the drop-down
menu...

@ 0C Workspace Launcher
Select a workspace

Eclipse Platform stores your projects in a directory called a workspace. Select the workspace directory to use for this session.
© Browse...

Workspace: /Users/djslater/Documents/My Projects ‘v

| Use this as the default and do not ask again

Cancel b ( OK )

When Eclipse has finished loading, you see a screen similar to the following:
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Loading an existing program

If you already have your program in project workspace (see above), but it is not in the Package Hierarchy window on the left of the
screen, then you need to make a project that contains the file(s). Follow these steps.

Select File->New->Project from the menu. You will get the following dialog.
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e 0o New Project
Select a wizard

Create a Java project

Wizards:

[J7 Java Project
4~ Plug-in Project
> =ovs
¥ =Java
[ Java Project
¥ (= Penumbra
@Simple]ava Project w/ Savitchin
P (= Plug-in Development
¥ (=Simple
1 Project

f Next > ’ ’ Cancel

Select the Java Project option and click on the Next> button. (Do not select the Simple option!)

In the following dialog, give a name to the project, the same name as the directory that contains the files (watch spelling and capitalization).
There should be a message indicating The specified external location already exists. Eclipse will then attempt to import all the resources
available at that location. Check Create project in workspace if it has not been selected.

e 0O O New Java Project
Create a Java project

Create a Java project in the workspace or in an external location. J ‘

Project name: greeterl
Location
@ Create project in workspace

: Create project at external location

Directory: /Users/djslater/Documents/My Projects/greeterl

Project layout

( Configure Defaults... )

The specified external location already exists. If a project is created in this location, the wi:

< Back \ / Next > \ ’ Cancel \ ( Finish )

Click on the Finish button.

The project appears in the left hand panel. Expand it, and also expand the default package icon. Double-click on one of the file names. The
file is displayed in an edit window:
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e o6 Java - GreeterTest.java - /Users/djslater/Documents/My Projects - Eclipse Platform
I3~ |B%:-/ tida—eu]35-0-Q |EH#EG &S] 1817 %04 B &lava =
[# Package Explorer Xir\Hierar(hv S @) [J] GreeterTest java ZZ\ =8 EEO R\':' B)
= ‘_" v v/* = v
* Created on Jan 5, 2005
> =bank L 3R e
> =FinalPrep N
Y greeterl ¥ O oo
¥ i (default package) v/ .,Gresets
M later
> [J] Greeter java . S" am using the Greete '
e yrogram using the Greeter class
¥ [J) GreeterTest.java .
> = RE System Library [JVM 1.4.2 ( wpublic class GreeterTest {
> Ehwl
> Ehwlsa - public static void main(String[] args) {
> & itester Greeter worldGreeter = new Greeter();
f System.out.println(worldGreeter.sayHello());
P = kareljrobot ° }
> 2 picture }
> 12 shapes
> IDJtoy
@
Problems [I&] javadcc|Search|ConsoIe| =8

Starting a new program

06/26/2006 11:18 AM

If you write a program from scratch, then you can start your work in Eclipse. It is always best to place each of your programs into a separate
directory. Eclipse will create the directory for you.

Select File->New->Project from the menu. You will get the New Project dialog.

Select the Java option and click on the Next> button. (Do not select the Simple option!)

In the following dialog, give a name to the project. Accept the default choices, Create project in workspace and Use project folder as
root for sources and class files
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e non New Java Project

Create a Java project

Create a Java project in the workspace or in an external location. J |

Project name: hwl
Location

@ Create project in workspace

~ . .
_ Create project at external location

Directory: /Users/djslater/Documents /My Projects/hwl Brows

Project layout

@ Use project folder as root for sources and class files

—~
_ Create separate source and output folders

( Configure Defaults...
~————

( <Back ) ( Next> ) ( cancel ) € Finish )

Click on the Finish button. Now locate the name of your new project in the left hand panel. Click on it with the right mouse button
(Windows) or control-click (Macintosh). Select New->Class from the context menu
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re 06 Java - GreeterTest.java - /Users/djslater/Documents/My Projects - Eclipse Platform R
[Nwits |Bl%-/ tde S|t 0-Q |B# G |® ] 181+ 5ls % dor Dy £ &ava »
W‘:— [J) GreeterTest java 2 = 8|Gzoxg\ = B
(= ‘:’ v v/* — v
* Created J 5, 2005
> 'bdbank . reate on an ’ laz Q b\s °
> IbJFinalPrep ./ \QL
> degreeterl
[ " v G.,Greett
= 4 Project... o
> Go Into §ing the Greeter class
> ”5] # Package
. ﬁ Open in New Window {
> % Open Type Hierarchy F4I™" & Interface in(String[] args) {
> = = o ter = new Greeter();
= Copy #C ?“ Source Folder n(worldGreeter.sayHello());
Paste ggv | (5 Folder
% Delete | LiFile
Source %S > E7 JUnit Test Case
Refactor 8T >
[ Other... ~“N
By Import... _
&5 Export...
«» Refresh FS
Close Project
Run >
Debug >
Team >
Compare With > &)
Restore from Local History... =
PDE Tools > ‘Iems @)Declaratlon = Javadoc|5earch|Console| B
aration - GreeterTest.java 5
Properties N ic class GreeterTest {
public static void main(String[] args) {
Greeter worldGreeter = new Greeter();
System.out.println(worldGreeter.sayHello()); -
} A
} B

| | hwl

The New Class dialog appears.

Supply the name of the class. If you want a main method for this class, check the box public static void main(String[] args).
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800

New Java Class

Java Class

(% The use of the default package is discouraged.

€

Source Folder: hwl M}
Package: (default)
D Enclosing type: Browse...
Name: [Hello
Modifiers: @ public () default ) private ) protected

[“Jabstract ] final | static
Superclass: java.lang.Object (' Browse.. )
Interfaces:

Which method stubs would you like to create?

™ public static void main(String]) args)
Q Constructors from superclass

[ Inherited abstract methods

Remove

€ Finsh) ( cancel )

Click on the Finish button.

Finally, you get an editor window into which you can type your program.

4

ene6 Java - Hello.java - /Users/djslater/Documents/My Projects - Eclipse Platform
It @|E% v/ dtaE8e|3-0-Q |[HFEG &S| SB]8-Fl oGy o &ava »
[% Package Explorer 2 Hieralchy’ =8 m CreeterTest.java m\ =0 35023 =0
2| B € - - /* =
> J =Y * Created on Jan 5, 2005 i s
hbank . BV Y e
> =>FinalPrep ‘Z( * TODO To change the template for this generated file go to . \L
> b‘lgreeterl * Window - Preferences - Java - Code Style - Code Templates
v S % v G.rde
¥ {1} (default package) oyee o
> 3] Hello java * @author djslater
P = JRE System Library [JVM 1.4.2 ( .
> b‘lhwm Zj * TODO To change the template for this generated type comment go to o
> b‘lltester * Window - Preferences - Java - Code Style - Code Templates
> o " */
. W larefirobot wpublic class Hello {
deplcture
P i=Zshapes v public static void main(String[] args) {
> oy }
}
@<
Problems @)Declaration 2 javadoc|$earch|Console| =8
Declaration - GreeterTest.java el
public class GreeterTest {
public static void main(String[] args) {
Greeter worldGreeter = new Greeter();
System.out.println(worldGreeter.sayHello()); ot
} 4
} v
— yalx

‘ Writable

| Smart Insert

[ 19:1
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As you type in your program, occasionally select File->Save from the menu to save your work.

You may enjoy the "content assist" feature of Eclipse. If you type a partial input and then hit CTRL+SPACE, a dialog shows all possible
completions. Just pick the one you want from the list.

'@ 6 Java - Hello.java - /Users/djslater/Documents/My Projects - Eclipse Platform
Hei"He | Bl% v S |30 QU | BHFCG | @S] @] FHloro oy 5 &ava >
1
[% Package Explorer £2 Hierarchyl = B[ [J] GreeterTest java M\ = P R =
| /| I ‘:’ B N L v
* Created on Jan 5, 2005
> =bank . L BV Y e
> 'bJFinaIPrep 72| * To change the template for this . file go to \t
> b‘lgreeterl * Window - Preferences - Java - (o - Code Templates V_ﬁ
v Ehwl o Hello
¥ {3} (default package) P o
> [J] Hello.java " dislater
P =, RE System Library [JVM 1.4.2 ( *
> b"hw14 Z, . DO To change the template for this generated type comment go to
> bJItester * Window - Preferences - Java Code Style - Code Templates
> = karelj
& lareljrobot wpublic class Hello {
P L= picture
P iz shapes - public static void main(String[] args) {
> oy System. gut,.
¥ © checkError() boolean - PrintStream
¥ @ close() void - PrintStream m
© equals(Object arg0) boolean - Ohject
© flush() void - PrintStream
@ getClass() Class - Ohject
© hashCode() int - Object
@ notify() void - Object
@ notifyAll() void - Object
© print(boolean arg0) void - PrintStream 2
@ print(char arg0) void - PrintStream 3
[ =) RIS
@
Problems @)Declaration bd JavadoclSearchIConsoleI =8
Declaration - GreeterTest.java e
public class GreeterTest {
public static void main(String[] args) {
H Greeter worldGreeter = new Greeter();
System.out.println(worldGreeter.sayHello()); g
} A
} v
(] )<T»
| | Writable Smart Insert 17:20

You may also want to experiment with some of the other convenience features of Eclipse, such as Source->Generate getter and setter.
Finding Errors

Even before compiling a program in Eclipse, the Editor can display problems in your program. (See the red X in the leftmost column in the
editor window below.)

By double-clicking on the red X, a description of the problem and some helpful options are displayed. In this case, you would click on
Change to 'System’' (java.lang)
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i ®en0e6e Java - Hello.java - /Users/djslater/Documents/My Projects - Eclipse Platform
It-He|E%  /VdtSm|3- 0 [# 6 |@F]|SB]8-Fi-oer o = & =
[£ Package Explorer £2 Hievarchyl = B[ [J] GreeterTest java m =0 EEOXZ =0
= -9 2 v/* L} v
* Created on Jan 5, 2005
> Iajbank " BV Y e
¥ =>FinalPrep Z] * TODO To change the template for this generated file go to NG
> b‘Jgreelerl * Window - Preferences - Java - Code Style - Code Templates
v Ehwl */ v O Hello
s
¥ {# (default package) o, o'
> [J] Hellojava * hor djslater
P = JRE System Library [JVM 1.4.2 ( *
> Ta‘Jth (2] » )0 To change the template for this generated type comment go to
» Bltes(er * Window - Preferences Java Code Style - Code Templates
> K */
Iadk.areljrobot wpublic class Hello {
P = picture
> Y17‘J5hapes - public static void main(String[] args) {
> Ka‘Jtoy x| . out.println("Hello World!");
} ¥ © Create local variable 'system ;;Jblic static void main(String([] args) {
o Create field 'system' [Object system;
© Create parameter 'system' Isystem.out.printin("Hello World!");
o Create constant 'system’ :
@ Change to 'System' (java.lang)
@ Change to 'SystemColor' (java.awt)
@ Change to 'SystemSigner' (sun.security.provider)
© Rename in file
O Create class 'system’
© Create interface 'system’
V
@
Problems K%Declaration =2 JavadocISearchIConsole! =8
Declaration - Hello.java ==
=
public class Hello {
public static void main(String[] args) {
system.out.println("Hello World!");
}
| e Ja»
| | system cannot be resolved Writable Smart Insert 17:15

Running a program

06/26/2006 11:18 AM

To run a program, right-click (Windows) or control-click (Macintosh) on the file with the main method, and from the context menu select the
Run->Java Application menu option. The program runs. Any console output is directed to a window at the bottom of the screen.
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m

e 06 ) "‘J-a-\);:l-.iénllé.java - /Users/djslater/Documents /My Projects - Eclipse Platform
lrcs- Bl %/ ctita Seu]i- 0@ |[E&HG]|®5] [BERRERR R R 5 &ava o
W\Hierarchvl =0 [ [3) GreeterTestjava (E’ Hellojava 2 = 8|gcoxg\ ~ 8
+« v /*
=ik S = v
* Created on Jan 5, 2005
> = bank ‘ noe : EZR Y e
> FinalPrep 7 change the template for -
> bdgreelerl - Preferences - Java - ( _(ﬁ
Y hwl v "HEILO
¥ £ (default package) " o'l
> O New »
> = JRE
> hwlse Open F3 D T e template for this go to
» bdltesler Open With > dow S Java Code Style C emplates
= .
. 'ka?'e'J'°' Open Type Hierarchy F4 |class Hello {
4= picture
> ';:Jshapes = Copy 38C lic static void main(String[] args) {
> bdtov Past £V System.out.println("Hello World!");
¥ Delete ®
Source \3S >
Refactor N®T 2
3 Import...
&4 Export...
References >
Declarations 2
<" Refresh FS
Run > ® 1 Java Application (e K1
Debug > insole 52 =8
Team > | O Run... [Library/Frameworks (JavaVM.framework/Versions/1.4.2 /Home/bin/java (Jan 5, 2005 12:03:
Compare With b [T —
Replace With L 28T
Restore from Local History...
Properties R\

| | Hello.java - hwl

Running applets

06/26/2006 11:18 AM

To run an applet, make sure the current project is still selected in the leftmost pane. Then select the menu option Run->Java Applet.

Eclipse will launch the applet viewer on the subclass of app1et that it finds in your project.

W | Applet... CarApplet.class | X

Applet

"

Applet started.

The applet viewer is started with a default size which is rather small. Just resize the applet window.

Close the window to terminate the applet.

Generating Javadoc comments

Select Project -> Generate Javadoc from the menu. You will get a dialog such as the following one:
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800 Generate Javadoc

Javadoc Generation

Select types for Javadoc generation. ]
L

1

Javadoc command:

ystem/Library/Frameworks /JavaVM.framework /Versions/1.4.2 /Home/bin/javadoc :J ’ Configure... \

Select types for which Javadoc will be generated:

: > bJ bank

: > L:J FinalPrep

: > LUJ greeterl

@ > hwl

O > & hwid

: > bJ Itester

m » J A
— =7 kareljrobot

[ T S RS Y

Create Javadoc for members with visibility:
: Private : Package : Protected @ Public
Public: Generate Javadoc for public classes and members.

@ Use Standard Doclet

Destination: /Users/djslater/Documents /My Projects/hwl/doc (" Browse.. )

~
. Use Custom Doclet

Doclet name:

Doclet class path:

Ba / Next> ) (€ Finish ) [ Cancel

06/26/2006 11:18 AM

Click the cleckbox for the project that you want to document. Then make sure that the destination directory is correct. Click on Finish.

Tracing through a program.

Before debugging a program, you should set a breakpoint at the start of the main method.

Double-click on the gray bar to the left of the edit window, next to the first source line after the line public static void main(String[]

args). A blue dot appears, indicating the breakpoint.
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¥ | Java - wordTestjava - Eclipse Platform &
File Edit Source Refactor Navigate Search Project Run

Window

|5y B B & |35 ke &

Help
| & v |® v|lw avar|B § 8

g t= Package Explorer v X m WordTestjava X ‘
- N - import java.util.StringTokenizer; [~
Byllw « @82 import javax.swing. JOptionPane;
- @car Rad e P “= impont declarations
% <~ 8 (default package) This program tests the countSyllables method of the Word class. 0* WordTest
cans
b @ ariava public class WordTest
P> @ CarAppletjava
[ "Q JRE System Library [j2sd public static void main(String[] args)
CarApplet.html
@ java.policy.applet
J StringTokenizer tokenizer = new StringTokenizer(input);
~ debugger H
= 99 while (tokenizer.hasMoreTokens())
<~ 8 (default package)
B[] wordjava String token = tokenizer.nextToken();
Word w = new Word(token);
int syllables = w.countSyllables();
P '}s JRE System Library [j2sd System.out.printin(“Syllables in * + token + : *
@ greeterl + syllables);
J
7 T hwl System.exit(0);
<~ 3 (default package)
b [ Helojava } v
D Wl JRE System Library [i2sd [<] [»]
7 & purse
< {3 (default package) B Console [<terminated> WordTest at localhost:13186) | ‘ &V f2} 0< X
P> @ ConsolelnputTestjavi| B
P m InputTest.java l
P [J] Pursejava E [v]
< | [»] |[<] [»]
Package Explorer | Hierarchy Tasks [Console |
Writable Insert |1 £

06/26/2006 11:18 AM

Then select the menu option Run->Debug as...->Java Application. The debugger starts and switches the Eclipse display to the debugger
perspective. It pauses at the breakpoint that you set.
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¥ | Debug - WordTest.java - Eclipse Platform

|5 B B & |35 kv &

File Edit Source Refactor Navigate Search Project Run  Window

Help

|® ¢ ||% «vs-[[[B]l & 8

= %5 Debug > i W i = IR R v X || vanables x
@ VroTaTesTIr: Tryvo - -
= =14
E:h Et <terminated> fusrlocalfji2sdk1.4.1_01/binfjava (3/25/03 9:34 AM) _‘ O args=Sting[0] (d=14)
%I A % WordTest [Java Application]
- & WordTest at localhost:5508
&) System Thread [Finalizer] (Running)
&) System Thread [Ref e Handler] (Running) ]
A qu Thread [main] (Suspended (breakpoint at line 12 in WordTest)] J %
= WordTest.main(String[]) line: 12 v] [<] [»]
I‘I ‘: I m - hi ‘n .r ll-r lmsphy
m\l‘v‘O!dfC‘SL_.‘.vl X ‘ EE Outline X
public static void main(String[] args) Rad
3 & ad]o
|| P “= impon declarations
StringTokenizer tokenizer = new StringTokenizer(input); 0* WordTest
while (tokenizer.hasMoreTokens())
{
String token = tokenizer.nextToken(); |
Word w = new Word(token);
int syllables = w.countSyllables(); (vl
e T A I O T A4
[] [»]
B Console [WordTest at localhost:5508] = ‘ &' a8 .1'74 X
E
v}
<« [»]
Console ‘Tasks
’Writable ‘Insen |12 160

06/26/2006 11:18 AM

Whenever you select the menu option Run->Step Over (or the F6 keyboard shortcut), then the debugger executes one line of the program,
without stepping inside method calls. For example, tracing over the call

Word w = new Word(token);

will not trace inside the word constructor but simply run the program to the next line of the main method.

Contrast that with the menu option Run->Step Into(or the F5 keyboard shortcut). This command traces inside method calls. For example,

tracing into the line

int syllables = w.countSyllables();

stops at the first line of the countsyliables method:

file:///Users/djslater/www/andrew/15-111/Eclipse%20Help/Eclipselntroduction.html

Page 13 of 16



Big Java / Computing Concepts with Java Essentials - Help - Eclipse

e |
File Edit Source Refactor Navigate Search Project Run  Window Help
@R &[Sk |[® v|[w evor B8 8
= %5 Debug B i W i = IR R v X || vanables % | v X
% Q Sy Thread [Ref e Handler] (R ing) ﬂ D @ this= Word (id=32)
w A4 qn Thread [main] (Suspended)
== Word.countSyllables() line: 38
= WordTest.main(String[]) line: 18
Q System Thread [Signal Dispatcher] (Running) _
&) Thread [AWT-Shutdown] (Running) J %
@ Thread [AWT-Motif] (Running) ] <] [»]
<[ | [»] Varahl ‘.. kpoints | Expressions | Display
[J] WordTest java | [ wordjava X ’ EE Outline x
‘A"“' -~
Counts the syllables in the word. | 6 laz L] o
@ return the syllable count - o Word
;;ublic int countSyllables() -] © © Word(String)
_ @ getText()
it end = textiengh) - 1
if (end < 0) return 0; // the empty string has no syllables o text: Sting
[ < | I > I
& Console [WordTest at localhost:5508] m B’y &8 F x
E
v}
Console [Tasks
’W'itable Insert |18 145

Watching values

06/26/2006 11:18 AM

To see the value of a variable of a simple type (such as a number or a string), simply hold the mouse pointer over the variable name when
the debugger is stopped. Then the contents of the variable is displayed in a small rectangle next to the variable name. For example, here is

the contents of the count variable in the countsyliables method.
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V| Debug - WordTest.java - Eclipse Platform

File Edit Source Refactor Navigate Search Project Run

|5y @ B & |35 ke &

Eclipse

Window  Help

|® ¢ ||% «vs-[[[B] ¢ 8

B |[$5oebus > 8 B & B I D .2 v X |0 varables
By @ System Thread [Reference Handler] (Running) ALD @ this=Word (d=32)
w 7 @y Thread [main] (Suspended) © count=0
— Word.countSyllables() line: 39
= WordTest.main(String[]) line: 18
Q System Thread [Signal Dispatcher] (Running) _
&) Thread [AWT-Shutdown] (Running) 4 %
CT’L Thread [AWT-Motif] (Running) 1 [&] I>]
‘I I I’I Variahl ‘n kpoi [- p - XDiSPhV
[J] WordTest java | m Word java X ’ EE Outline X
‘A'" -~
Counts the syllables in the word. | 6 laz Q o
@ return the syllable count
j v @ word
public int countSyllables() ] © © Word(String)
X tText
int count = 0; I _. getTexto =
- rdTest at localhost:5508] count = (int) 0 EinisyRlesl)
if (e syllables o text: String
S SO S Y hd
[¢] [»]
& Console [WordTest at localhost:5508] BBy &8 4 x
E
[+]
<« [»]
Console ‘Tasks
Writable Insert |18 145

The top right window shows all local variables. Click on the triangles to look inside objects. To see the instance fields of the implicit

parameter, look inside this.

()3 Vanables b ‘ v X
'~ @ this= Word (id=36)

@ text= null
P @& s="is"
< bl
Varahk |.. kpoints | Expressions | Display

06/26/2006 11:18 AM

The top left window shows the call stack (with the most recently called method on top). For example, the following call stack shows that the
WordTest.main Method called the word.<init> method, that is, the constructor.

Foebug > H B P = BI DR

X

@) System Thread [Ref e Handler] (F ing)
7 @y Thread [main] (Suspended)

= WordTest.main(String(]) line: 17
&) System Thread [Signal Dispatcher] (Running)
&) Thread [AWT-Shutdown] (Running)
€ Thread [AWT-Motif] (Running)

[ ]

Setting breakpoints

Tracing through a program can be tedious. Often, you want the program to run at full speed until a particular line of code is encountered. To
set a breakpoint at a line, double-click on the gray bar to the left. A blue dot indicates the breakpoint.
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Word, X

== € E

boolean insideVowelGroup = false;
for (inti=0;i<=end; i++)

{

| ch = Character.toLowerCase(text.charAt(i);
String vowels = “aeiouy”;
if (vowels.indexOf(ch) >=0) D
{
chis avowe
if (linsideVowelGroup) E]
[¢] [*]

Now select the menu option Run->Resume or hit the F8 keyboard shortcut. The program runs to the next breakpoint, stopping only for user
input.

You can set as many breakpoints as you like.
To remove a breakpoint, double-click on it with the mouse.
Stopping the debugger

When the program has completed, the debugger stops automatically. When you want to terminate a debugging session without running the
program to the end, select the menu option Run->Terminate.

To return to the Java perspective (in which you can edit and compile your program), locate the perspectives toolbar at the left of the Eclipse
frame:

Click on the button with the "J" (above the bug button). Eclipse will remove the debugger windows and restore the edit windows.
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