Lesson 07
Polygonal modeling

In this lesson, you will create Boog, the bear from the Sony Pictures Animation Inc. movie Open Season. The character will be created starting from primitives. You will use many polygonal tools and deformers until the desired shape is achieved. As you learned in the first project, it will be possible to edit the construction history of modeling actions to update the model as you go. As well, you can edit the results throughout the lesson until you delete the history.

In this lesson you will learn the following:

- How to model starting from a cube primitive;
- How to model using polygon proxy;
- How to mirror geometry;
- How to work with polygonal components;
- How to edit the topology of a polygonal model;
- How to work with procedural modeling attributes;
- How to change edge normals;
- How to use a lattice deformer.
Set up your project

Since this is a new project, you must set a new directory as your current project directory. This will let you separate the files generated in this project from other projects. If you want to look at the final scene for this lesson, refer to the scene 07-boog osg.mel.

1. Set the project
   As you have already learned, it is easier to manage your files if you set a project directory that contains sub-directories for different types of files that relate to your project.
   - If you copied the support files onto your drive, go to the File menu and select Project → Set...
   - A window opens pointing you to the Maya projects directory.
   - Click on the folder named projectc to select it.
   - Click on the Ok button.
   - This sets the projects directory as your current project.

   OR
   - If you did not copy the support files on your drive, create a new project called projectc with all the default directories.

2. Make a new scene
   - Select File → New Scene.

Starting the bear

You will build the bear starting from a polygonal cube primitive. Faces will be extruded to create the more complex biped shape required and will then be refined to create the bear shape.

It is important to understand what you will be doing throughout this lesson, so you must plan ahead and breakdown the task into simple stages. The following is how you will approach the character modeling.

Torso

The cube primitive will be the pelvis area of the bear. You will then extrude faces up to create the torso, neck and head.

Legs

Starting from the pelvis geometry, you will extrude the polygon faces to create the legs.

Arms

Starting from the torso geometry, you will extrude polygon faces to create and refine the arms.

Later in the lesson, you will ensure that your model is symmetrical by mirroring it.

Tip: It is a good idea to look at reference images from this project and from the gallery in this book to give you an idea of the finished product.

1. Primitive cube
   - Select Create → Polygon Primitives → Cube.
   - Press s to Smooth Shade All.
   - Rename the cube to body.
   - From the Inputs section of the Channel Box, set the Subdivisions Width of the polyCube node to 2.

Doing so will define polygonal edges going down the central line of the character.

Tip: As a general convention, you should always model your characters facing the scene’s positive Z-axis.

- Move the cube up and scale it to roughly match the following, which represents the waist of the character.

Start primitive cube
When modeling, don't be afraid to model big. You do not want to be stuck working on a tiny model. Use the grid as a reference to represent the floor. You can always edit the proportions of your character later on.

Extrude faces

Before extruding the faces, you need to make sure that the Keep Faces Together option is enabled. When this option is On, it extrudes chunks of facets instead of each facet individually. Following is an example of Keep Faces Together both On and Off:

Tip: During the process of modeling the orb, make sure that you do not accidentally select, deselect, or modify facets that are on the opposite side of the object. If you do, use Ctrl to deselect unwanted components.

- Select the Polygons menu set by pressing F3.
- Make sure the option Edit Mesh → Keep Faces Together is set to On.
- Go to Component mode with faces displayed by pressing F13, or by setting the selection mask in the Status Bar as follows.
3 Subdiv Proxy
So far, you need a bit of imagination in order to see the bear’s shape. _Subdiv Proxy_ is a simple tool that allows you to see a smoothed version of your model while still modeling on the cube from the previous steps.

- Go in Object mode.
- With the cube selected, select Proxy → Subdiv Proxy.

Doing so displays the original geometry, known as the proxy, with transparency, and displays the smoothed resulting geometry within it. Whenever you update the proxy geometry, the smoothed version will automatically update. Once you have refined the proxycape to your needs, you can either get rid of the smoothed version and keep working on the proxy geometry or vice-versa.

![The proxy and smoothed geometry](image)

**Tip:** You should never tweak the smoothed version of the geometry directly.

- Press the `[ ]` hotkey (the key on the upper left corner of your keyboard), to toggle between the proxy and smoothed geometry.

4 Extruding the legs
Now that you can see the rough shape of the bear’s body, you need to extrude the legs. Here, you will extrude both legs at the same time.

- Select the proxy geometry and display its faces.
- Select the two faces from underneath the pelvis to start extruding the legs.
- Select Edit Mesh → Extrude.
- Move and scale the extruded faces down to the bear’s knees.

**Note:** When you manipulate the handle associated with one face, the other face reacts equally. Extrusions work according to the normals of the original faces. Normals are lines that run perpendicular to the surface. To view polygon surface normals, select Display → Polygons → Face Normals.

- Extrude again to the ankles.
- Rotate the faces by about 45 degrees in order to flow the next extrusion into the feet.
3 Extruding the arms
   Since you should be concentrating only on the basic shape of the character, you will stop
   refining the legs here and go right into extruding the arms.
   • Select the faces on either side of the torso.

   **Tip:** While selecting, remember to use Shift to toggle the new selection, Ctrl to deselect and
   Ctrl+Shift to add the new selection.

   • Extrude the arms up to the elbows and roughly tweak the placement of the new faces.
   • Extrude again up to the wrists and roughly tweak the placement of the new faces.
   • Extrude one last time to create the palms, and roughly tweak the placement of the new faces.

5 Save your work
   • Save your scene as o7_bear_arma.

---

Shaping the bear
Now that the basic shape of the bear is established, you can concentrate on moving polygonal
vertices around to refine the general silhouette of the bear.

   **Tip:** For a quick look at the silhouette of the character, you can press 7 on your keyboard.
   Without lights in your scene, this makes an instant black silhouette.

1 Tweak the proxy
   In order to define the shape of the bear a little better, you do not need to add geometry yet.
   Instead, you can edit the proxy geometry's vertices.
   • Select the proxy geometry.
   • Go in Component mode with vertices displayed.

   • Double-click on the Move Tool in the Toolbox to bring up its options.
   • In the Move Tool options, set the following:
     - Reflection to On.
     - Center to Bounding Box.
     - Reflection axis to X.
     - Tolerance to 0.1.
   • Click on the Close button.
   • Select a vertex on the proxy geometry and move its position.

   *Because of the reflection option in the Move Tool, the corresponding symmetrical vertex
is also moved.*
2 Modelling tips

- With vertices selected, you can press the arrows on your keyboard to traverse the geometry components.
- Make sure to always look through different views when modeling. You can stay in the Perspective view, but be sure to use the View Compass located in the upper right corner.

Tip: In the construction history of the polyChamfer node, you can change the width of the chamfered vertex.

Refine the bear

You should now add more geometry to play with in order to get the bear to the next level. Here, you will add to the existing geometry in order to better define key areas such as the tail, feet, and hands.

1 Chamfer a vertex

Before you can extrude the tail of the bear, you will need an actual polygon face to extrude the tail from. The Chamfer command allows you to select a vertex and cut the proper face division in order to convert that vertex into a face.

- Select the one vertex located at the lower back of the bear.
- This is the vertex from which you will extrude the link
- Select Edit Mesh → Chamfer Vertex.

Tip: You can turn on the wireframe on shaded option by selecting Shading → Wireframe on Shaded. This will allow you to see the underlying geometry on the smoothed geometry.

Try to not move the central line of vertices on their X axes. This will make your work easier when you mirror the geometry.
3 Splitting a polygon
The last face on the top of the tail should be split vertically in order to comply with the central line dividing your character along the chest, neck and head.
- Select Edit Mesh ➔ Split Polygon Tool.
- Click+drag to the top edge of the hexagonal face.
- Click+drag to the bottom edge of the hexagonal face.

2 Extrude the tail
- Extrude the tail face twice as follows:

Tip: Select all the tail face vertices and use the Scale Tool to make the face perfectly flat on its Z-axis.

4 Flatten the feet
As you can see, the smoothed bear model does not have flat feet. This can be fixed by extruding an additional face underneath the feet.
- Select the faces under both feet.
- Select Edit Mesh ➔ Extrude
Doing so forces the smoothed version of the geometry to be flatter in that area.
- Using the extrude manipulator, scale the faces so they are smaller.
5. Thumbs

The hands of your character should be very simplistic, with only long claws coming out of them. The thumb area could still use some definition.

- With the proxy selected, press Ctrl +
  This reverts the Subdiv Proxy functionality to the body geometry only.
- Zoom in onto one hand of your character.

- Select Edit Mesh → Insert Edge Loop Tool.

Note: An edge loop is defined by a continuous line of connected edges. The edge perpendicular to the edge loop is called an edge ring.

- Click and drag on one of the palm edges in order to insert an edge loop as follows:

  Inserting an edge loop

- Extrude and modify the thumb face in order to bring out the thumb.
- Press Ctrl + to enable the Subdiv Proxy model.
- Extrude again and tweak the resulting shape as follows:

  The extruded thumb
6. Mirror the geometry

The last few steps done to extrude the thumb are not reflected on the other hand. Rather than redoing all the work for the other side, it is simpler to create a mirrored version of your geometry. This will also simplify your work once you begin modeling the character's face.

- With the proxy geometry selected, press Ctrl+ to go back to your original body geometry.
- From the front view, select all the faces on the left side of the character.

- Hit the Delete key on your keyboard.
- Go back in Object mode and select the body geometry.
- Select Edit → Duplicate Special → Ctrl.
- In the duplicate options, select Edit → Reset Settings, and then set the following:
  - Geometry Type to Instance.
  - Scale X to -1.
- Click the Duplicate Special button.

7. Save your work

- Save your scene as og_boog_oz.ma.

Refine the head

Perhaps the most important part of the character is the face. This exercise will go through some steps in order to refine the head, but most of the work will have to be done by yourself, since this is an artistic task.

Several new tools will be explained here with some key examples that will require experimentation. If you would like to use the final scene of this exercise as a reference, look for the scene og_boog_cog.mai in the support files.
1 Delete the construction history
After all the operations done thus far on the model, the construction history list is starting to look impressive, but also useless. Now is a good time to delete the history on your model. This also deletes history from the entire scene.
- Select Edit → Delete All by Type → History

2 Offset Edge Loop Tool
The head is now very simplistic and the first step is to add more geometry to play with. You will add several edge loops for the neck and head.
- With the body geometry selected, select Edit Mesh → Offset Edge Loop Tool.
  This tool allows you to simply add two edge loops on either side of an existing edge loop.
- Click and drag on any horizontal edge at the top of the neck.

- Release the mouse button to execute the tool and insert the new edges.

3 Delete edges
If you need to delete edges, it is possible to simply select them and press the delete key on your keyboard. However, working this way leaves vertices on the perpendicular edges that are not wanted. In order to compensate for this, there is a specialized command that can be used to correctly delete edges and vertices.
- Select Select → Select Edge Loop Tool

This tool requires you to double-click on an edge in order to select its related edge loop.
- Deselect any edges by clicking in an empty space in the viewport.
- Double-click on one of the edges from which you used the offset command in the last step. The entire edge loop is selected.
- Select Edit Mesh → Delete Edge/Vertex.
The entire edge loop is properly deleted.

4 Insert an edge loop
There are several ways to access the different modeling commands other than with the menus. If you like working with the menus, keep doing so, but following is an alternative that involves a hotkey and a Marking Menu.
- Deselect any edges from the body geometry.
- Choose one of the vertical edges from the lower part of the neck.
- Hold down the Ctrl key and then RMB on the geometry. This brings up a polygon modeling Marking Menu.
- From the Marking Menu, select Edge Ring Utilities. Doing so automatically pops a second Marking Menu related to edge rings.
• Select To Edge Ring and Split.
  The command automatically selects the related edge rings about the chosen edge and then does a split on those edges.

5. Insert more edge loops
• Insert two more vertical edge loops on the nose of the character.

6. Split polygons
  Notice that when you use the Insert Edge Loop tool, the tool stops splitting polygonal faces with four sides. If it encounters polygonal faces with more or less than 4 sides, the tool stops splitting more edges. This can be very useful, but it can also go through your entire character before it stops splitting edges. In order for you to control how many edges are split, the tool has an option that allows you to choose the start and end edge to split. Following is an example of such an application.
  • Select Edit Mesh → Insert Edge Loop Tool.
  • Click on one of the vertical edges on the side of the character's head.
  • Undo the last operation.
  • Double-click on the Insert Edge Loop Tool in the bottom portion of the Toolbox or select Edit Mesh → Insert Edge Loop Tool → ③.

• In the shown window, turn Off the Auto Complete option.
• Click the Close button.
• Click the central vertical edge on the top of the nose.
  The tool now requires you to choose subsequent edges in order to define an edge loop.
• Choose the edge at the base of the neck.
  The tool displays the solved edge ring.

Note: You can keep selecting other edges to define a longer edge loop. The edges do not need to be part of the same edge ring.

• Hit the Enter key when you are ready to insert the proposed edge ring.

7 Tweak the head vertices
There is now much more geometry to refine in the head area. This is where the artistic work comes in, and where you must use your own judgment to define the head to your liking. In the following, you will use different options in the Subdiv Proxy command.

• Delete the instance geometry.
• Select the body geometry.
• Select Proxy ➔ Subdiv Proxy ➔ 3.
• Set the following in the option window:
  - Mirror Behavior to Full;
  - Mirror Direction to –X;
  - Merge Vertex Tolerance to 0.1.
Since your geometry has been split in half, setting this option will automatically make a mirrored and merged geometry.

• Click the Smooth button.
• Select the proxy geometry.
• Go in Component mode with vertices enabled.
• Tweak the head vertices as follows:

8 Save your work
• Save your scene as 07_bear_03.ma

Keep on modeling
You now have a good understanding of polygonal modeling basics. By continuing to refine the bear character, you will see that the time spent experimenting will provide valuable experience. Throughout the modeling process, you can get into trial and error processes that will eventually achieve great solutions. At some point, you will be able to visualize the different steps to take without ever touching the model!

Following are some general directions to finish modeling the head of the character. To see the final scene of this exercise, look for the scene 07_bear_03.ma in the support files.

1 Removing the proxy
The proxy geometry is a great way to create a general shape for your character, but at some point, you will need to refine the smoothed version. Proxy geometry will need to be deleted when refining the higher resolution model.

• Select Edit ➔ Delete All by Type ➔ History.
  Doing so removes any history between the proxy and smooth geometry.

• Select the body proxy geometry and its mirrored instance, and then hit the Delete key.
• Rename the high resolution geometry to body.

2 Tweak the vertices
Now that you have more vertices defining your character, you can play with the shape of the bear.
Tip: Don’t be afraid of moving vertices one by one. You will most likely end up moving each vertex by hand for the entire model anyway.

While you are tweaking the vertices around the eyes, nose, mouth and ears, try to delimit the different facial areas with edges. Doing so will help to see the different parts of the face and it will also make it easier to split polygons to get even more resolution.

3 Add divisions
You must now concentrate on splitting and refining only one half of the model. Consider deleting half the model and creating another mirrored instance as shown previously.
- Using the Split Polygon Tool, insert new edges where required in order to better define certain areas.

Tip: As a rule, try to always create four-sided polygons when splitting geometry. Doing so will spare you problems later on.

4 Extrusions
- Extrude faces to create the nostrils.
- Extrude faces to create the ears.

5 Soft normals
The extrusion and polygon splits create hard edges by default.

The following shows how to soften polygonal normals.
- With the body geometry selected, select Normals → Soften Edges.

6 Mouth
For simplicity reasons, you will not see how to model the inner mouth in this lesson. Instead, concentrate on modelling the lips in order to clearly define the mouth.

7 Merging the model
At this point, you can continue refining the model, or call it final and go on with the rest of the project. The following shows how to mirror and merge the actual geometry in order to create a final complete body.
- Delete the instanced geometry.
- Select the body geometry.
- Select Mesh → Mirror Geometry.
- In the options, specify the Mirror Direction to be -X.
- Click the Mirror button. The geometry is mirrored and then merged together to create a full body.

8 Merging edges
It is possible that through the process of modeling, you moved central vertices off the mirror plane, causing the geometry to have opened edges along the central axis. The following shows how to merge those edges.
- Select the body geometry.
- Select Display → Polygons → Border Edges.
- Doing so causes border edges to be displayed with a thicker wireframe line.
- Press Q to see your model in wireframe.
• Select Edit Mesh → Merge Edge Tool.
  
  This tool allows you to choose two edges and force them to merge together.

• Choose any of the opened thicker edges.
  
  Possible edges to be merged with are highlighted in pink.

• Choose the pink edge located on the other half of the model.
  
  Hit Enter to merge the edges.
  
  The edges should not be closed.

• Repeat the previous steps for any other open edges.

9 Final steps

• With the body geometry selected, select Normals → Soften Edges.
  
  Select Edit → Delete All by Type → History.

10 Save your work

• Save your scene as 09-soft_04.ma.

Proportions

Sometimes when modeling, you sit back and look at your work thinking you could improve the proportions of the model. An easy way to change a model’s proportions is to create and modify a lattice deformer. A lattice surrounds a deformable object with a structure of points that can be manipulated to change the object’s shape. Once you are happy with the new proportions, you can simply delete the history, thus freezing the deformations on the models.

1 Create a lattice deformer

• Select the body geometry.
  
  From the Animation menu set, select Deform → Create Lattice.
  
  A large lattice box is created around your model.

2 Deform the lattice box

• RMB on the lattice object in the viewport to bring up the lattice context menu and select Lattice Point.

• In the Channel Box with the lattice selected, set the fhLatticeShape node as follows:
  
  S Divisions to 5;
  
  T Divisions to 5;
  
  U Divisions to 3

Doing so will change the amount of subdivisions in the lattice deformer, which in turn adds more lattice points to deform the surface with. This will allow more control over the deformations.

Tip: You may adjust these settings to better fit your geometry and divide the model into body part sections.

The lattice context menu

• Select lattice points and transform them just like you would do with vertices.
  
  Notice how the lattice points deform the geometry.
Final touches

The body of the bear looks great, but Blox is still missing key components such as eyes and claws. These objects will be created starting from NURBS primitives.

Just like the rest of this lesson, you will model only half the geometry and then mirror it over to the other side.

1 Eyeball

- Select Create → NURBS Primitives → Sphere.
- Rename the sphere to eyeball.
- Translate and scale the eyeball to the proper eye location.
- Rotate the eyeball by 90 degrees on its Z-axis.

2 Eyelid

- With the eyeball selected, select Edit → Duplicate Special → Shift-

In the shown window, select Edit → Reset Settings, then turn on the Duplicate input graph option.

This option duplicates the geometry along with all its inputs, such as construction history, which will be used here.

- Click the Duplicate Special button.
- Rename the duplicate to eyelid.
- From the Channel Box, rotate the eyelid by 90 degrees on its Y-axis.
- Scale the eyelid so that it is a little bigger than the eyeball.
- In the Channel Box, highlight the motorNurbsSpheres input node.
- Set the Start Sweep to 20 and the End Sweep to 340.

The eyelid will use its construction history in order to simplify the eye blinks.

Tip: This is a good time to place the character's feet on the world grid, if they are not already. Also, make sure to place the model's center of gravity centered on the Z and X-axes.

1 Delete the deformer

If you would simply delete the lattice deformer, the geometry would snap right back to its original shape. In order to keep the deformation and freeze the geometry with that shape, you need to delete its history, which will automatically delete the deformer.

- Select the body geometry.
- Select Edit → Delete By Type → History.
3 Claws
- Create a NURBS cone primitive.
- Set the makeNurbsCone input node as follows from the Channel Box:
  - Radius to 0.2.
  - Sections to 4.
  - Spans to 2.
  - Height Ratio to 10.
- Rename the cone to claw.
- Place and tweak the claw's shape as in the adjacent image.
- Duplicate the claw in order to create all the other ones for the hand and foot.

Tip: You can go in the duplicate options and select Edit -> Reset Settings before duplicating the first claw since the construction history is not required.

4 Mirror the objects
- Select the eyeball, eyelid and all the claws.
- Press Ctrl+g to group them all together.

5 Save your work
- Save your scene as 07-bogey_05.ma.

Conclusion
In this lesson, you learned how to model a complete character out of basic polygonal primitives. In the process, you used several polygonal modeling tools to create the shape and details. As you noticed, each tool created an input node for which you were able to modify the construction history. You also used the lattice deformer, which is a great deform to know about.

In the next lesson, you will texture the bear. This will allow you to experiment with polygonal texture tools and techniques.