Mulberry 3.1 Advanced Features
for Windows and Macintosh Machines

A Computing Services Publication - June 21, 2004


Introduction

This document provides instructions for using the advanced features of the Mulberry email client. Advanced Mulberry features include:

Other documents of interest:

 


Displaying the To and CC Headers

Follow these steps to Collapse or Expand the window header. You can use this option to display and print the complete contents of the To and Cc headers messages if desired.

  1. In Mulberry, open a message from any remote mailbox.
  2. Select Window > Collapse Window Header.

    Click here for larger image.
  3. Select Window > Save Default Window to set the default for all messages to be displayed in Collapsed view.

    Note: You can also Expand or Collapse the header into the message body by clicking on the bar in the upper left corner of the message window. If you only want to use the collapsed view when printing messages, skip this step. The Expanded (standard) view will remain as the default view for all messages.

Showing/Hiding Header Information

Follow these steps to display or hide the message header. You can use this option to display and print the path of your messages if desired.

  1. Select Message > Show Header to display the path of where and when a message was sent and received followed by the message content.



    Note: You can also click on the toggle button located next to Formatted on the message window to Show and Hide Header information.

Setting up SMTP Auth and Sending Mail Using a Third-Party ISP

When using Mulberry from a computer that is not part of the Carnegie Mellon network (e.g. when dialing-up through: AOL, EarthLink, Stargate, etc.), it is necessary to modify your configuration so that you can send messages to all Internet users. This functionality is useful for those who are traveling on business, or for those who use a third-party Internet Service Provider (ISP) for availability, performance or other reasons.

Follow these instructions to verify or set-up SMTP Auth:

  1. Select File > Preferences (Windows) or Mulberry > Preferences (Macintosh).
    The Preferences window is displayed.
  2. Select the Accounts tab.
  3. Click on the Account field and select SMTP.
    Note: This account might be called SMTP or Andrew SMTP. You will know that you have the right account if the Type field (located below the Account field) displays SMTP Send Mail.
  4. Set the Server field to smtp.andrew.cmu.edu.
  5. Select the Authenticate tab and set the Method to Kerberos V4.
    Make sure that the following options are enabled:
    • Use Default Server Principal
    • Use Default User ID
  6. Close the Accounts tab.
  7. Click on the Identities tab.
  8. Select the Default identity from the Identities list and click Change.
    The Identity Edit dialog box appears.
  9. Verify that the SMTP account is set to SMTP for which you just enabled SMTP Auth.
    Note: This account might be called SMTP, smtp, or Andrew SMTP.
  10. Click OK to dismiss the dialog box.
  11. In the Remote Preferences window, click OK.
    Your preferences are saved to the remote preferences server.

Managing your Mail Account Disk Quota

Initially, students, faculty and staff members are allocated 25MB of space on the mail server with a maximum quota of 100MB. Follow these instructions to determine the size of your allocated mail space:

  1. Select one of your personal folders (i.e. INBOX) and click Details located on the menu bar.
    The Details dialog box is displayed.
  2. Click on the Quota tab and then on the + (Windows) or the down arrow (Macintosh) that is next to your name to reveal your allocated mail space.

Adding a Size Column to a Mailbox Window

To better monitor the use of your space, you can increase the "size" column of your Mulberry mail client. Follow these steps to enable the size column in the Server panel:

  1. Launch Mulberry and right-click (Windows) or Control click (Macintosh) on the column header in the Mail window.
  2. Depending on where you want the new column to appear in relation to the column you selected, select either Insert Column Before or Insert Column After.
  3. Right-click (Windows) or Control click (Macintosh) on the new column heading and select Size for its type. You can widen the column for easier viewing by placing the cursor on the edge of the column heading; the cursor will become a sizing arrow.

    NOTE: Under the Size column heading, a small red and blue icon appears.
  4. Click on the icon to reveal the size of the selected folder. For example, select the Sent mail folder, and then click on the red and blue icon. The amount of space used by your sent mail appears in bytes or kilobytes.

Follow these steps to enable the size column of your INBOX window:

  1. To determine the size of each message in your INBOX, right-click (Windows) or Control click (Macintosh) on the column header in the INBOX window. Depending on where you want the new column to appear in relation to the column you selected, choose either Insert Column Before or Insert Column After.
  2. Right-click (Windows) or Control click (Macintosh) on the new column heading and select Size for its type.

    Click here for larger image.

    You can widen the column for easier viewing by placing the cursor on the edge of the column heading; the cursor becomes a sizing arrow. The size of the message appears in the size column. You'll notice that messages with attachments are much larger than messages with no attachments.

  1. Once you've enabled the size column of the Mulberry window, you can easily enable the size column in other windows. With the INBOX window open and selected, choose the Windows menu, then select Save Default Window.

Using Disconnect Mode

Disconnect Mode allows you to store messages in remote mailboxes on your computer's hard drive so that you can access them when your computer is not connected to a network (e.g., while traveling). These messages can be read and otherwise manipulated in the normal manner. Any changes made to a message while in Disconnect mode will be reflected in their online counterparts the next time a network connection is established.

To prepare Mulberry for disconnect mode you must first enable disconnected operations in your Cyrus account. To do this, follow these steps:

  1. Select File > Preferences (Windows) or Mulberry > Preferences (Macintosh).
    The Remote Preferences window appears.

    Note: If the window does not look like the graphic below, select the Advanced radio button on the right side of the Remote Preferences window.

  2. Select the Accounts tab, then select Cyrus from the Account: pull down menu.
  3. On the tabs located below the Cyrus pull down menu, select the Options tab.
  4. Select the Allow Disconnected Operations checkbox.
  5. Click OK to close the Remote Preferences window.

Next, you must identify the inboxes that you wish to access while in Disconnected Mode. Follow these steps:
  1. In the Server pane, select Cabinet > Auto Synchronise.
    The Auto Synchronise cabinet appears.
  2. Mailboxes you want to view or manipulate while disconnected must be added to the Auto Synchronise cabinet. To do this, select each mailbox and drag them onto the Auto Synchronise cabinet.
  3. To view the contents of the Auto Synchronise cabinet, click the plus sign (Windows) or the triangle (Macintosh) that appears to the left.
While still connected to the network, you'll need to switch into Disconnect mode. Follow these steps:
  1. Select File > Disconnect.
    The Disconnect dialog box appears.
  2. Set your disconnect options as you desire (e.g., Synchronize All Messages, Synchronize New Messages, etc.). To view a list of the mailboxes that will be synchronized, click on the triangle that appears to the left of the Show Mailbox Information text. Files listed here are the only files that will be syncronized.
  3. When all disconnected options are set, click OK to begin the synchronization process.
    After synchronization is complete, Mulberry closes all network connections and is in Disconnect Mode. As a reminder "(Disconnected)" appears in the banner of the Servers window.

  4. Select File > Preferences (Windows) or Mulberry > Preferences (Macintosh). The Remote Preferences window is displayed.
  5. On the right side of the Remote Preferences window under Storage, select the Local radio button.
  6. Click Save As.
  7. Save the preferences file in a location on your hard drive (preferably on your desktop so it's easy to find). You'll need to launch Mulberry from this file to use Disconnect mode.
  8. Click OK to close the Remote Preferences window, then close Mulberry.

Follow these steps to launch and use Mulberry in Disconnect Mode.

  1. With your computer disconnected from the network, double-click on the preferences file you created in step 4-8 above to launch Mulberry. We recommended that you save this file to your desktop.
  2. Mulberry launches (you may generate a "file not found" error message; click OK to dismiss and ignore the message) and the inboxes that you elected to synchronise are displayed. While disconnected, you can read and respond to mail messages for these inboxes.

    Note: Messages will not actually be sent until you establish a network connection and launch Mulberry in Connect mode once again. See steps below.

Follow these steps to synchronise and use Mulberry in Connect Mode.

  1. Establish a network connection. To launch and synchronise Mulberry, double-click on the preferences file you created in steps 4-8 above.
  2. Select File > Connect.
    The Connect dialog box is displayed.

  3. Click OK to begin the synchronization process.
  4. After synchronization has completed, the Connect dialog box disappears. Mulberry will be in connected mode, and you can use it as you normally would. Messages that were part of a sychronised inbox will be automatically handled (e.g., sent). You'll notice that the banner of the Server pane displays "(Connected)".

Using Mail Filters with Mulberry 3.1

Notice:
You can use Sieve with any e-mail client. However, you must be running Mulberry 2.1 or higher to generate sieve scripts. If you need to upgrade your copy of Mulberry, visit My Andrew to download the latest copy.

Based on one, or a series of matching rules, mail filters can discard mail, bounce it back to the sender or file it into a specific folder. This document walks you through the process of creating and enabling mail filters using the Mulberry mail client. The following topics are discussed:

Note: The Help Center will not troubleshoot mail filtering. If the mail filter fails to function as you expected, you should delete it and try again.
Note: Images included in this documentation reflect the Windows version of Mulberry. Macintosh screen displays will appear differently.

What is the difference between local and sieve mail filtering?

Local filtering offers a wide variety of matching criteria and occurs only while you are actually running the mail client (e.g. Mulberry, Outlook) where you have defined local rules. Local filtering allows you to sort by header information or by specific information contained in the body of the message.
Sieve filtering is handled on the mail server side. With sieve filtering, it makes no difference if the mail client is running or not since the mail is filtered before it ever reaches your inbox. Sieve filtering is fundamental to vacation mail--you're not running your mail client but the server is still filtering your mail as it arrives. Unlike local filtering, sieve filtering can only filter headers (e.g., To, From, Subject, Date).

Caution: Since sieve filtering is done before the message ever reaches your inbox, there is no record of sieve filtered email-- it is not delivered to your INBOX. This should be a consideration before you attempt to implement a server-side sieve filter.

Creating a Local Mail Filter

There are three basic steps when you are creating a local mail filter using Mulberry:

Define the Rule

In order to define mail filters, you must be using Mulberry version 2.1 or higher. Follow these steps to define a new mail filter:
  1. From the main Mulberry menu bar, select Mailbox > Rules.
    The Rules dialog box is displayed with the Local tab selected. Click on the Rule button.

  2. The Email Rules dialog box is displayed.
  3. Create a logical name for the rule and enter it in the Name field.
  4. The next step is to define matching rules for this filter. You will define your matching rules by selecting criteria from the pull-down menus. For example, if you want to develop a filter that copies all mail from John Smith into a personal mail inbox that you've created and named "personalmail" you would:
    • enter personal mail or another appropriate name in the Name field
    • in the first Find Message Whose (Windows) or If Messages Match (Macintosh) field, select From Address from the pull-down menu.
    • in the next Find Message Whose (Windows) or If Messages Match (Macintosh) field, select Contains from the pull-down menu.
    • enter John Smith in the Contains field
    • in the Actions pull down menu, select Copy Message to from the first pull down menu
    • enter the name of the mail folder you want to copy this message to or click the down arrow to browse and select a mail folder
    In this example, the Email Rules dialog box might look like this:
  5. Click OK to close the Email Rules window. The Rules window reappears and displays the newly added mail filter. The name of the filter will be displayed in an italicized font since it has not yet been enabled.
  6. You can expand the criteria of the "personalmail" filter created in the previous step. For example, if you also wanted to file mail from Mary Jones into your personalmail folder, you would:
    • double-click on the personal mail rule you created in the previous step (or select it and click on the Edit button)
    • click on the More Choices button
    • select and from the and/or pull down menu
    • select From Address in the first Find Messages whose pull down menu
    • select Contains in the second Find Messages whose pull down menu
    • enter Mary Jones in the text field box next to the Contains pull down menu
    In this example, the Email Rules window would look something like this:
The following list explains the pull down menus and the filtering criteria that you can select from.
From Messages whose:
    From Address The "From" address of the message
    To Address The "To" address of the message
    CC Address The "CC" address of the message
    Bcc Address The "BCC" address of the message
    Recipient Matches either the To, CC, or Bcc addresses in the header.
    Correspondent Matches any address in From, To, CC or Bcc message headers that is not one of your addresses or an alias.
    Sender Matches the Sender address in the message header.
    Date Sent The date the message was sent.
    Date Received The date the message was received.
    Subject The subject text of the message.
    Body The body text of the message.
    Header field The header text of the message.
    Entire Message The entire message, including all headers and the message body.
    Size The size of the message.
    Recent Flag The recent flag of the message.
    Seen Flag The seen flag of the message.
    Answered Flag The answered flag of the message.
    Important Flag The important flag of the message.
    Deleted Flag The deleted flag of the message.
    Draft Flag The draft flag of the message.
    Contains The selected field contains the following text.
    Does not Contain The selected field does not contain the following text.
    Is Me The selected address field contains my email address. This option
    will only be available if an address field is selected.
    Is Not Me The selected address field does not contain my email address. This
    option will only be available if an address field is selected.
Action
    Set Flag Sets the specified flag on the matching messages.
    Unset Flag Removes the specified flag from the matching messages.
    Copy Message To Copies the matching messages to the specified mailbox. This action does not set the deleted flag after the
    copy operation, even if the ‘Delete Message after Copy’option is on in the Message>Options preference panel.
    Move Message To Copies the matching messages to the specified mailbox and then sets
    the deleted flag on all of those messages. The deleted flag is always set, even if the ‘Delete Message after Copy’ option is off in the Message>Options preference panel
    Reply to Message Generates replies to the matching messages, one for each matched
    message. A number of options for generating the reply are available.
    Forward Message Generates forwarded messages for the matching messages, one for
    each matched message. A number of options for generating the
    forward are available.
    Bounce Message Generates bounces to the matching messages, one for each matched
    message. A number of options for generating the bounce are
    available.
    Expunge Message Expunges (permanently removes) the matching messages from their
    mailbox. Only those messages in the matching set that have their deleted flag turned on will be expunged. Thus an Expunge action will likely be preceding by a ‘Set Flag Deleted’ action or a ‘Move Message to’ action.
    Play Sound Plays the specified sound when matching messages are found.
    Display Alert with Display an alert box on screen with the specified text appearing in
    the alert when matching messages are found.
    Speak with Speaks the specified text when matching messages are found.

Define a Trigger

Triggers are different types of events that can be used to run a set of rules. Each trigger specifies what type of event it is governed by. Rules are then added to the trigger and those rules will be executed when the trigger runs.
Triggers are created and configured via the triggers list in the Rules Manager window. Each trigger has a user supplied unique name. Triggers can be explicitly enabled or disabled. Disabled triggers appear in the Rules Manager window with their names displayed in italic text.
Follow these steps to create a trigger:
  1. From the main Mulberry menu, select Mailboxes, then select Rules. The Rules dialog box appears with the Local tab displayed. Click on the Show Triggers button.
    Note: To view rules and triggers at the same time, position your cursor on the left edge of the Rules window and slide the window open.

  2. To add a trigger, position your cursor in the white area on the Triggers side of the window, then click on the Trigger button.
  3. The Email Rules window appears. In the Name text box, enter an appropriate name, then click on the down arrow in the Apply field to select a trigger.


    The following list explains each of the trigger functions:
  4. Never The trigger never runs. This can be used to disable a trigger without deleting it.
    New Messages Arrive The trigger runs when new messages are detected when opening a mailbox, or when an open mailbox is checked. This trigger will only be applied to messages that are unseen, not deleted and not drafts, in addition to any other search criteria specified by its rules.
    Opening a Mailbox This trigger runs whenever a mailbox is opened.
    Closing a Mailbox This trigger runs whenever a mailbox is closed.
    All The trigger runs when any of the three previous events occur.
  1. To enable this trigger, be sure that the Enabled checkbox has been selected.
  2. Click OK to close the Email Rules window.

Apply Trigger and Enable

To enable a rule, you must apply an enabled trigger to it. Follow these steps:
  1. From the main Mulberry menu, select Mailboxes, then select Rules. The Rules window appears.
  2. To enable the personal mail rule with the Always trigger (both created in previous examples) do either of the following:
    • Click and drag the personal mail rule to the Always trigger. You can click on the + sign that appears in front of Always to view any rules assigned to that trigger
    • Double-click on the personal mail rule. When the Email rules window appears, click on the Triggered by: pull down menu and select the Always trigger.
  3. The personal mail filter is now enabled with the Always trigger. Notice that enabled rules and triggers do not appear in italics.

Creating a Sieve Mail Filter

There are four basic steps to developing a sieve or server side mail filter using Mulberry.

Define a Sieve Rule

In order to define a mail filter, you must be using Mulberry version 2.1 or later. Follow these steps to define a sieve mail filter:
  1. From the main Mulberry menu, select Mailboxes, then select Rules. If the Rules dialog box appears with the Local tab displayed, click on the SIEVE tab, then click on the Rule button.

  2. The Email Rules dialog box appears.

  3. Create a logical name for the rule and enter it in the Name field.
  4. The next step is to define matching rules for this filter. You'll define your matching rules by selecting criteria from the pull down menus. For example, if you want to develop a sieve filter that files all mail that includes "big money " in the Subject field of the message, you would:
    • enter big money or another appropriate name in the Name field
    • in the first Find Message Whose pull down menu, select Subject
    • in the next Find Message Whose pull down menu, select Contains
    • enter big money in the Contains field
    • under Actions select File into from the pull down menu
    • enter the name of the mail folder you want to file this message into or click the down arrow to browse and select a mail folder
    In this example, the Email Rules dialog box might look like this:


  5. Click OK to close the Email Rules window. The Rules window reappears and displays the newly added mail filter.
    The following tables explain the pull down menus and the sieve filtering criteria that you can select from.

    From Messages whose:
    From Address Matches the From address in the message header
    To Address Matches the "To" address in the message header
    CC Address Matches the "CC" address in the message header
    Bcc Address Matches the "BCC" address in the message header
    Recipient Matches either the To, CC or Bcc addresses in the message header
    Correspondent Matches either any address in From, To, CC or Bcc message headers that is not one of your addresses or an alias.
    Sender Matches the Sender address in the message header
    Subject Matches the Subject text in the message header
    Header Field Matches text in a chosen message header
    Size Matches the size of the message
    All Messages Messages Always matches

    Note: The second pull down menu under the Find Messages whose area is a list of dynamic choices that are dependent on the selection you made above, for example: is, is not, contains, etc.

    Actions:
    Keep The message will always be delivered to the ‘default’ mailbox
    (usually INBOX), in spite of any actions that come before or after this one.
    Discard The message will be removed and not be delivered to any mailbox. There will be no error message to indicate the message
    was removed.
    Reject The message will be sent back to its sender and will not be delivered to any mailbox. You can specify text to be used in the
    rejection notice sent back to the sender of the original message.
    Redirect The message will be bounced to an address that you specify and will not be delivered to any mailbox.
    File into The message will be delivered into the mailbox that you specify. Mailboxes other than INBOX can only be used when SIEVE is available with an IMAP server. The mailbox that you specify must be a valid mailbox for the SIEVE server. If the mailbox does not exist, the message will instead be delivered to the ‘default’ mailbox.

Copy the Rule and Enable

In order to enable the sieve mail filter you created in the previous steps, you must first copy it to the server. Follow these steps:
Copying the Rule
  1. From the main Mulberry menu, select Mailboxes, then select Rules. If the Rules dialog box appears with the Local tab displayed, click on the SIEVE tab. The sieve mail filter created in the previous step is displayed in italics.
  2. Select the sieve rule that you want to enable (in the example above, "Big Money"), then click on the Edit button. The Email Rules dialog box is displayed. Click on the Edit Script Component check box. The Email Rules window displays the actual sieve script.
  3. Select the entire script, then press Ctrl + C (Apple + C on Mac) to copy it to your clipboard. Click OK to close the Email Rules window.
  4. Use a web browser (e.g., Internet Explorer, Netscape, etc.) to visit the My Andrew web page. In the My Email section, click on the Set mail filters/sieve script link. A page appears similar to the following:

  5. On the Sieve Script web page, click on the Enter a New Sieve Script button. A screen display similar to the following appears.
  6. In the Script Name field, enter an appropriate name for this script. In the script text box, press Ctrl+V (Apple + V on Mac) to paste the script that you copied in step 3.
  7. With the Edit a Sieve Script web page still displayed, you must enter the following syntax at the beginning of the sieve script
    require ["fileinto", "reject"];

    so that the completed script appears similar to the following:
  8. Click on the Submit button. The script is submitted and a screen display similar to the following appears:
  9. To enable the script, select the script (in this example, "big money"), the click on the Enable button. The screen display returns with the script designated as enabled.

Define Multiple Sieve Rules

Only ONE sieve script can be enabled at any given time. However, a single sieve script may include as many rules as you like. For example, to add additional rule(s) to an existing sieve script you would:
A sieve script that includes two rules might look something like the following.
Note: The require ["fileinto","reject"]; syntax is added once at the beginning of the script, not once for each rule.
Note: All rules are matched sequentially unless you define a stopping point. To define a stopping point, select the Stop if Matched box when defining the rule through Mulberry.

 Archive/Save Messages to a File

You are able to easily save an individual or group of messages to file within Mulberry.

  1. Select the email message(s) that you want to archive.
  2. Select File > Save.
  3. If you selected more than one message, the following dialog box displays.
    • Click Multiple to save each email selected in its own file.
    • Click Single to save all of the selected email messages in one file.
  4. Select the location where you want to save the message(s) and enter a file name.
    Note: If you elected to save multiple messages to their own files, you will be prompted to enter a name for each message that you selected.